The referenced components 'Telerik.OpenAccess.40.Extensions', 'Telerik.OpenAccess.MySql.Data' and 'Telerik.Sitefinity.WorkflowActivities' could not be found.

May 18, 2011 at 12:45 PM

Hi,

I have to upgrade a Sitefinity web site from 3.7 to 4.0, and I decided to use the Sitefinity Migration Tool, 0.6 Beta 3, followed the steps from the documentation. 

I'm stack on fix missing references from for Migration project because of 3 warnings:

The referenced component 'Telerik.OpenAccess.40.Extensions' could not be found; 

The referenced component 'Telerik.OpenAccess.MySql.Data' could not be found;

The referenced component 'Telerik.Sitefinity.WorkflowActivities' could not be found.

I have also build errors, but I suppose are caused by the missing references.

(The errors are like:

The type or namespace name 'Lists' does not exist in the namespace 'Telerik.Sitefinity.Modules' (are you missing an assembly reference?)

The type or namespace name 'Migration' does not exist in the namespace 'Migration' (are you missing an assembly reference?)



)

If anyone can help me fix the problem, I appreciate,  

thanks 
  
   

May 27, 2011 at 9:55 PM

I removed them from the list of broken references and the code compiles OK. Did you try that?

I did not get errors compiling (file date: May 2, 2011)

May 27, 2011 at 10:30 PM

Yes, I tried, thank you, jboyer, still errors.

The solution was to use the latest 4.1 Sitefinity version (the latest version of Project Manager) instead of 4.0. The referenced components are still missing but no errors this time.

So I finally managed to reach the end of the preparing migration story.

Now I have everything in place and ready to "Begin Migration". 

But "Begin Migration" do.. nothing...

In console tab of the FireBug I can see the error message "JQuerry is not a function......" 

Can you give me an idea on how this can be fixed?

 

Thank you, 

May 30, 2011 at 8:51 PM

You are farther away... I still cannot get the migration screen to open. But I am using SP1 - are you using 4.1 BEFORE SP1? Thanks. I will look in the jQuerry...

May 31, 2011 at 12:06 PM

I use directly 4.1. sp1, (before, I used only 3.7), Sitefinity Project Manager 4.1.1395.0 and the Migration tool 9031. The Migration page was loading only after I double click the project from Sitefinity Project Manager  (after clear browser cache and close the VS Sitefinity 4 project). The Migration menu should be in the "Content" menu.